Multidomain-Migration von Nodes mit mehreren VLAN Interfaces


#1

Mit dem Upgrade auf das Multidomain-Setup wird die Mesh-Kommunikation über Kabel in VXLAN enkapsuliert. Nur wenn an beiden Kabelenden die gleiche VXLAN-Id anliegt wird eine Verbindung entstehen.

In großen Offloader-Installationen wurden häufig VLANs eingesetzt um auf großem Gelände den Management-Traffic zu reduzieren indem man ein vollständiges Mesh verhindert. Das senkt auch die Belastung schwacher Embedded-Router und schafft mehr Kapazität für Nutzlast.

Um diese Konfiguration erneut zu erreichen sind zwei Änderungen notwendig. Hier im Beispiel beschreiben wir die nötigen Änderungen anhand eines Mesh-Interface namens mesh_vlan120.

  1. :warning: Maximale Namenslängen einhalten:

    • Interfacename: nicht länger als 12 Zeichen
    • Firewall-Zone: nicht länger als 14 Zeichen
  2. In /etc/config/firewall muss die wired_mesh Zone dupliziert werden, und dann das mesh_vlan120 in die Liste von Netzwerken einzufügen:

    config zone 'mesh_custom'
    	option name 'mesh_custom'
    	option input 'REJECT'
    	option forward 'REJECT'
    	option output 'ACCEPT'
    	list network 'mesh_vlan120'
    	
    config rule 'mesh_custom_ICMPv6_in'
    	option src 'mesh_custom'
    	option limit '1000/sec'
    	option family 'ipv6'
    	option target 'ACCEPT'
    	option proto 'icmp'
    	list icmp_type 'echo-request'
    	list icmp_type 'echo-reply'
    	list icmp_type 'destination-unreachable'
    	list icmp_type 'packet-too-big'
    	list icmp_type 'time-exceeded'
    	list icmp_type 'bad-header'
    	list icmp_type 'unknown-header-type'
    	list icmp_type 'router-solicitation'
    	list icmp_type 'neighbour-solicitation'
    	list icmp_type 'router-advertisement'
    	list icmp_type 'neighbour-advertisement'
    	list icmp_type '130/0'
    	list icmp_type '131/0'
    	list icmp_type '132/0'
    	list icmp_type '143/0'
    
    config rule 'mesh_custom_vxlan'
    	option dest_port '4789'
    	option src 'mesh_custom'
    	option name 'mesh_custom_vxlan'
    	option src_ip 'fe80::/64'
    	option family 'ipv6'
    	option target 'ACCEPT'
    	option proto 'udp'
    
  3. In /etc/config/network das proto-Feld auf dem Interface auf gluon_wired aktualisieren

    Vorher:

    config interface 'mesh_vlan120'
    	[...]
    	option proto 'gluon_mesh'
    	[...]
    

    Nachher:

    config interface 'mesh_vlan120'
    	[...]
    	option proto 'gluon_wired'
    	[...]
    

Die Änderungen werden nach einem Neustart des Netzwerks

# /etc/init.d/network restart

oder nach einem Neustart aktiv.

# reboot

1.2.4 - Richtungsweisend
1.2.6 - Just In Time
1.2.5 - Strippenzieher
#2

#3

Dieser Beitrag wurde soeben aktualisiert. Es genügt nicht weitere Interfaces der wired_mesh Zone hinzuzufügen, da dies nicht updatefest ist.

Schritt 1 der Anleitung wurde daher überarbeitet.