IP-Adresse konnte nicht abgerufen werden

Hallo zusammen,

mein Freifunk Router (64579-Syndicated) Archer C7 V2 erlaubt es nicht, Verbindungen aufzubauen.

IP-Adresse konnte nicht abgerufen werden

Im Config-Mode sieht alles gut aus und es ist auch die aktuellste Stabile Firmware draufgespielt.

Der WAN-Port ist mit meiner Fritz!Box (192.168.178.1/24) verbunden.
Um ein DHCP-Problem im WAN auszuschließen, habe ich dem Archer die statische IP 192.168.178.55 zugewiesen, was allerdings nichts genutzt hat.
Auf den LAN-Ports wird das WAN-Netzwerk propagiert, somit dient der FF-Router noch als Switch für mein privat-Netzwerkes.

Wenn ich nun im nicht-config-mode versuche per SSH zu verbinden kommt:

timbo@DESKTOP-J039BAU:~$ ssh root@192.168.178.55
ssh: connect to host 192.168.178.55 port 22: Resource temporarily unavailable

Im Config-Mode kann ich mich per SSH erfolgreich verbinden.

Meine Fritz!Box (192.168.178.1) hängt hinter einem UnityMedia-Kracher im Bridged-Mode, sodass die Fritz!Box das Routing, Firewall etc. übernimmt. Den IPv6 Support habe ich aktiviert, mit “Native IPv6-Anbindung verwenden” und “Globale Adresse ausschließlich per DHCPv6 beziehen”.

Ich vermute, dass auf meinem Freifunk Router der DHCP-Server nicht ordentlich funktioniert. Aber ohne SSH-Zugang weiß ich mir nicht weiter zu helfen.

Hat jemand eine Idee?

Vielen Dank
TimBo

Laut Karte ist dein Knoten seit 42 Tagen offline. Kann mich nicht an irgendwelche Änderungen bei uns erinnern, die dafür Auslöser sein könnten.

Wenn du sagst, dass auf dem Switch auf dem Freifunk-Router dein WAN-Netz anliegt, dann hast du ja sicher die /etc/config/network verändert. Vielleicht ist dabei etwas schief gegangen?

Ich habe das gerade probiert, übers LAN komme ich in meinen Freifunk-Router rein.

Vielleicht ist es Zeit den fastd key zu sichern, und einen reset durchzuführen.

1 Like

Hallo Hexa,

danke für deine Antwort.
Ich habe vor einigen Monaten im IRC nach Unterstützung gefragt, das WAN über den Switch zu exposen. Hier wurden mir ein paar Befehle gesagt, an die ich mich allerdings nicht genau erinnern kann. Ich meine, dass man die Einstellungen geändert und anschließend Committen musste.

Das mit dem WAN auf dem Switch finde ich halt sehr praktisch, da ich so etwas sparsamer bin, und keinen zusätzlichen Switch betreiben muss. Der Switch funktioniert auch noch einwandfrei. Nur das WLAN ins Freifunk geht leider nicht mehr.

Die Einstellung hat auch einwandfrei funktioniert, bis vor 42 Tagen die Verbindung ins FF wohl kaputt gegangen ist. Mir ist es nicht direkt aufgefallen, da den FF Zugang hauptsächlich meine Nachbarn / Freunde etc. benutzen.

Schöne Grüße
TimBo

Das klingt so als ob die clientN WLAN interfaces nicht mehr in der Client-Bridge (br-client) sind. Am betsten gehst du im Config-Mode mal per SSH rein und kopierst die /etc/config/network mal heraus und zeigst uns die.

das ist meine aktuelle Config-Datei

root@64579-syndicated:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdbd:d763:7b7a::/48'

config interface 'wan6'
        option sourcefilter '0'
        option ifname 'br-wan'
        option ip6table '1'
        option peerdns '0'
        option reqprefix 'no'
        option proto 'none'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4 5'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '6'

config interface 'wan'
        option multicast_querier '0'
        option peerdns '0'
        option auto '1'
        option type 'bridge'
        option igmp_snooping '1'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '192.168.178.55'
        option netmask '255.255.255.0'
        option gateway '192.168.178.1'

config rule6 'wan6_lookup'
        option mark '0x01/0x01'
        option lookup '1'

config route6 'wan6_unreachable'
        option type 'unreachable'
        option table '1'
        option target '::/0'
        option metric '65535'
        option gateway '::'
        option interface 'loopback'

config interface 'mesh_wan'
        option ifname 'br-wan'
        option transitive '1'
        option index '0'
        option proto 'gluon_wired'
        option disabled '1'

config interface 'mesh_lan'
        option igmp_snooping '0'
        option ifname 'eth1'
        option transitive '1'
        option macaddr '6a:be:db:2c:77:d4'
        option index '4'
        option proto 'gluon_wired'
        option disabled '1'

config interface 'mesh_vpn'
        option ifname 'mesh-vpn'
        option transitive '1'
        option macaddr '6a:be:db:2c:77:d7'
        option fixed_mtu '1'
        option proto 'gluon_mesh'
        option mtu '1312'

config interface 'mesh_radio0'
        option proto 'gluon_mesh'

config interface 'mesh_radio1'
        option proto 'gluon_mesh'

config interface 'client'
        option igmp_snooping '1'
        option type 'bridge'
        option auto '1'
        option ra_holdoff '30'
        option multicast_querier '1'
        option macaddr 'f4:f2:6d:70:a6:80'
        option ipv6 '1'
        option keep_ra_dnslifetime '1'
        option sourcefilter '0'
        option peerdns '0'
        option robustness '9'
        option reqprefix 'no'
        option query_interval '2000'
        option query_response_interval '500'
        option proto 'dhcpv6'
        list ifname 'bat0'
        list ifname 'local-port'
        list ifname 'eth1'

config device 'local_node_dev'
        option type 'veth'
        option name 'local-node'
        option peer_name 'local-port'
        option macaddr 'da:ff:07:00:ff:ff'
        option peer_macaddr 'f4:f2:6d:70:a6:80'

config interface 'local_node'
        option ifname 'local-node'
        option ipaddr '10.84.127.254/20'
        option ip6addr 'fd01:67c:2ed8:1007::1:1/128'
        option ip6deprecated '1'
        option proto 'static'

config interface 'gluon_bat0'
        option gw_mode 'client'
        option proto 'gluon_bat0'

config interface 'bat0'
        option multicast_router '2'
        option ifname 'bat0'
        option auto '1'
        option macaddr 'f4:f2:6d:70:a6:80'
        option learning '1'
        option proto 'none'

config route6 'local_node_route6'
        option target 'fd01:67c:2ed8:1007::/64'
        option gateway '::'
        option interface 'client'

Hm, die Radio Interfaces werden wohl über den network key in ihrem ẁifi-ifaceblock eingehangen. Magst du die/etc/config/wireless` auch noch dazulegen? Falls du die privates WLAN Funktion nutzt bitte den PSK schwärzen.

gerne. :slight_smile:
Meine /etc/config/wireless sieht folgendermaßen aus:

root@64579-syndicated:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'pci0000:01/0000:01:00.0'
        option country 'DE'
        option txpower '20'
        option htmode 'VHT20'
        option channel '48'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/qca955x_wmac'
        option htmode 'HT20'
        option country 'DE'
        option txpower '20'
        option channel '5'
        option legacy_rates '0'

config wifi-iface 'mesh_radio0'
        option ifname 'mesh0'
        option network 'mesh_radio0'
        option device 'radio0'
        option mesh_fwding '0'
        option mesh_id 'ffda-mesh-dom7'
        option mcast_rate '12000'
        option mode 'mesh'
        option disabled '0'
        option macaddr '6a:be:db:2c:77:d1'

config wifi-iface 'mesh_radio1'
        option ifname 'mesh1'
        option network 'mesh_radio1'
        option device 'radio1'
        option mesh_fwding '0'
        option mesh_id 'ffda-mesh-dom7'
        option mcast_rate '12000'
        option mode 'mesh'
        option disabled '0'
        option macaddr '6a:be:db:2c:77:d5'

config wifi-iface 'client_radio0'
        option ifname 'client0'
        option network 'client'
        option disabled '0'
        option device 'radio0'
        option mode 'ap'
        option macaddr '6a:be:db:2c:77:d0'
        option ssid 'darmstadt.freifunk.net'

config wifi-iface 'owe_radio0'
        option ifname 'owe0'
        option network 'client'
        option encryption 'owe'
        option device 'radio0'
        option ieee80211w '2'
        option disabled '0'
        option mode 'ap'
        option macaddr '6a:be:db:2c:77:d2'
        option ssid 'owe.darmstadt.freifunk.net'

config wifi-iface 'client_radio1'
        option ifname 'client1'
        option network 'client'
        option disabled '0'
        option device 'radio1'
        option mode 'ap'
        option macaddr '6a:be:db:2c:77:d4'
        option ssid 'darmstadt.freifunk.net'

config wifi-iface 'owe_radio1'
        option ifname 'owe1'
        option network 'client'
        option encryption 'owe'
        option device 'radio1'
        option ieee80211w '2'
        option disabled '0'
        option mode 'ap'
        option macaddr '6a:be:db:2c:77:d6'
        option ssid 'owe.darmstadt.freifunk.net'

Das verstehe ich leider nicht ganz. Das Wifi (2,4 und 5GHz) sollte eigentlich ausschließlich dazu genutzt werden, um FF zu ermöglichen. Mein privates WLAN für meine Heimgeräte wird separat über die Fritz!Box (2,4 und 5GHz) aufgespannt.

Hm, die Radio Interfaces werden wohl über den network key in ihrem ẁifi-ifaceblock eingehangen.

das kann ich leider nicht beantworten.

Aus der OpenWrt network initialization

ucidef_add_switch "switch0" \
			"0@eth1" "2:lan" "3:lan" "4:lan" "5:lan" "6@eth0" "1:wan"

Das heißt: Switchport 6 → eth0 und Switchport 0 → eth1

Aktuell hast du dein WAN auf eth0 und dein FFDA Client-Netz auf eth1, weshalb aktuell dein Heimnetz mit dem Freifunk-WLAN gebrückt is.

Editiere am besten die Switchconfig, so dass port 1-6 in einem VLAN sind und port 0 isoliert oder nicht verbunden.

Ich habe dir relevanten Stellen in den Config-Sektionen mal zum besseren Verständnis zusammengestellt:

config interface 'wan'
        option ifname 'eth0'

config interface 'client'
        list ifname 'eth1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4 5'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '6'

Modifikationen an der Netzwerkconfig würde ich nur mit deaktiviertem Autoupdater laufen lassen, ansonsten kann bei einem Update das leider passieren :confused:

Vielen Dank blocktrron für die Analyse des Problems.

ich habe aus der

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4 5'

die 0 bei ports entfernt. Anschließend habe ich den Router neu gestartet. Leider funktioniert das Freifunk-WLAN nach wie vor nicht und ich komme weder über den LAN, noch über den WAN Port per SSH auf den Router. Was kann ich in so einem Fall machen?

Ich dachte

0@eth1 und 6@eth0
würde nur das WLAN betreffen, da 2 bis 5 ja LAN und 1 der WAN Port ist.

Anscheinend habe ich das Konzept nicht richtig verstanden.

Gute intention, leider hast du damit effektiv alle Netze von den beiden Ports, die vom Switch zum SoC gehen genommen :grinning_face_with_smiling_eyes: Aber keine sorge, das kriegt man wieder ohne großen Act gerade.

Vielleicht macht das auch

ucidef_add_switch "switch0" \
			"0@eth1" "2:lan" "3:lan" "4:lan" "5:lan" "6@eth0" "1:wan"

etwas verständlicher.

Das sind die beiden relevanten komponenten deines Problems. Oben der Switch, unten der SoC. Wie oben bereits erwähnt, hast du zwei 1Gbit/s Links richtu gn SoC an jeweils Port 0 und 6 des switches.

Das Netz, was du richtung CPU haben willst, musst du also auch auf Port 0 oder 6 legen. Port 0 ist mit eth0 verbunden, Port 6 mit eth1.

In deinem Fall müsste

option ports '1 2 3 4 5 6'

gesetzt sein (und das alte VLAN 2, welches nur einen member port hat löschen), da Port 1-5 die physikalischen Ports am Gerät sind und eth0, welches dein WAN da stellt mit Port 6 des switches verbunden ist. Port 0 bleibt in diesem Fall dann unbenutzt.

OpenWrt (und auch Gluon) haben einen Failsafe mode. Diesen ektivieren, danach kannst du dich via ssh auf der 192.168.1.1 einloggen. (Der Router macht kein DHCP, also statische IP konfigurieren). Mittels mount_root kannst du das rootfs mounten und deine Config editieren.

Danach den Router einfach neu starten.

Hey @blocktrron
das Schaubild ist sehr gut und dadurch habe ich die Konfiguration besser verstanden. :slight_smile:

Habe jetzt die Ports 1-6 in switch_vlan ‘1’ und das switch_vlan ‘2’ mit nur Port 6 dran gelöscht. Und siehe da - es funktioniert einwandfrei. Die 4 LAN Ports propagieren nun das WAN und das WLAN für Freifunk steht. Wunderbar!

Vielen Dank und ein schönes Wochenende
TimBo